无法自动更新VistaSP1原因和方案

无法自动更新Vista SP1原因和解决方案

 
  微软公布了一份新的知识库文章KB948343,详细解释了为何无法在Windows Update上发现Vista SP1,以及如何应对。  为了帮助用户解决Windows Vista SP1升级中的问题,微软公布了一份新的知识库文章KB948343,详细解释了为何无法在Windows Update上发现Vista SP1,以及如何应对,对今后简体中文版的更新也有较强的指导意义。
  如果Windows Update和自动更新都找不到Vista SP1,那么看看你是不是存在以下8种问题之一:
  1、已经在运行Vista SP1
  2、系统语言不在Vista SP1首发版本之列。
  3、使用Windows SP升级包拦截工具禁止自动更新。
  4、曾经试图安装Vista SP1,但由于文件或注册表冲突而失败。
  5、硬件设备驱动或设备软件与Vista SP1不兼容。
  6、曾经安装过Vista SP1测试版,但还没有卸载。
  7、曾经使用第三方工具vLite配置过系统,删除了升级Vista SP1所需要的部分系统组件。
  8、曾经隐藏过Windows Update提供的可选更新,而这些更新是升级SP1的前提。
  对应的解决方法依次如下:
  1、检查系统版本,卸载已经安装的Vista SP1测试版。
  2Vista SP1目前只有英语、法语、德语、日语和西班牙语五种语言版本,其他31种语言版本还要再等一段时间。
  3、请禁用Windows升级包拦截工具。详情可以参考这里。
  4、联机检查解决方案。
  5、为了保证系统升级的可靠性,Windows Update暂时不会向包含部分设备驱动和应用软件的系统提供Vista SP1,因为微软认为这些驱动、程序和Vista SP1存在兼容性问题。具体如下:
  音频设备驱动:
  Realtek AC9732Alcxwdm.sys64Alcxwdm64.sys版本为6.0.1.6242或更旧
  SigmaTel32Sthda.sys64Sthda64.sys版本为5.10.5762.0或更旧
  SigmaTel32Stwrt.sys64Stwrt64.sys版本为5.10.5762.0或更旧
  HD Audio32Chdart.sys64Chdart64.sys版本为4.32.0.0或更旧
  Creative Audigy32Ctaud2k.sys版本为6.0.1.1242或更旧;32P17.sys的所有版本(这原本是Windows XP驱动)
  生物指纹传感器:
  Intel Display32Igdkmd32.sys64Igdkmd64.sys版本在7.14.10.13227.14.10.1403之间
  其他设备:
  德州仪器智能卡控制器:GTIPCI21.sys文件版本为1.0.1.19或更旧
  Sierra Wireless AirCard 580无线网卡:Watcher.exe程序版本为3.4.0.9或更旧
  赛门铁克Endpoint ProtectionNetwork Access Control客户端:32Wgx.sys64Wgx64.sys版本为11.0.1000.1091或更旧
  用户可以在Windows Update上查找新版驱动,或者向服务提供商索取,当然也可以在网上搜索下载。
  6、在Vista RTM基础上升级安装Vista SP1测试版的可以直接卸载;直接安装集成板Vista SP1测试版的必须直接升级正式集成版,或者卸载后依次安装RTMSP1
  7、不要使用vLite给系统盲目减肥
  8、在Windows Update上选择还原已隐藏的更新,尽量安装提供的所有升级补丁,包括KB935509KB938371KB937287等等。